	
	
[image: image1.emf]Advanced Microsoft Word

Sorting and Calculating


	Sorting Text:  Microsoft Office allows you to rearrange your text by numbers first, then letters [alphanumerically]; by numbers only’ or by date.  You can sort tables, paragraphs, or lists created with commas, tabs, spaces, or other separators.  You can sort in either ascending [A to Z 1 to 10, earliest date to the latest date.] or descending [Z to A, 10 to 1, latest date to earliest] order.

Any blank lines you have inserted between paragraphs in your document will automatically be moved to the top or bottom of the selection during the sort.
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• Each time you sort during a Word session, 

the previous sort settings are retained.  Be 

sure to check all settings before you click 

OK to sort.


	When entering text, you do not need to enter list items in order.  You can use Word’s Sort Feature to reorder list items in a number of ways.

To sort a list [or to perform any other kind of sort]. Open the Table menu and choose Sort.  The Sort Text dialog box opens.

 Perform a simple sort by selecting the item to sort by [usually Paragraphs] and type of item to sort [text, number, or date].  Choose the Ascending or Descending option, and then click OK.  Notice that you can sort by more than one criterion using the additional Then by boxes.

 Clicking the OPTIONS button in the Sort Text dialog box opens the Sort Options dialog box.  In this dialog box, Word gives you additional options for controlling the sort.  For paragraphs that contain more than single words, you can instruct Word to sort text by FIELDS.  In this case, the fields are a single piece of information, such as the first word or the second word.  Tabs, commas, or other characters may separate the fields.  Click the CASE SENSITIVE option to have Word sort by both upper- and lowercase letters.  
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• Name Title Department Date Hired

• Lisa Foster-Hale Director Legal 3-15-71

• Roger Lee Director Public Relations 4-5-80

• Terry Curran Manager Personnel 7-14-82

• Shelley Metzger Administrative A Finance 6-30-85

• Lucille Graszl Administrative  Legal 1-16-88

• Larry CraszlSales Representative Marketing 12-17-89

• Richard Derrenberger Clerk III Accounting 4-6-90

• Mildred RushSales Representative Marketing 2-7-91

• Anne Pheifer Receptionist Personnel 9-14-92


	When sorting table data, you can sort a single column or the entire table.

When you want the entire table sorted based on the first column, you can use a button the Tables and Borders toolbar to perform the sort automatically.  If the result is not what you expected, you can open the Table menu, choose Sort, and check the settings.

 Furthermore, you can sort by multiple words contained within a single table column.  For example, if the column contains both first and last names, you can sort by either the last name or the first name.
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• EXERCISE

• Open Expense Report

• Sort in descending order

• Calculate total for each column

• Center and bold the column headings

• Right-align the amounts in each column

• Save


	Word provides a calculation feature that enables you to add numbers in text and in tables.

When calculating sums in a paragraph of text, you simply select the paragraph and then choose Table Formula command on the Table menu.

When calculating sums in a table, Word provides an easy shortcut to total the columns and/or rows.

To perform a calculation in a table, position the insertion point in the CELL [where a row and column intersect in the table] where the total [result] is to appear, open the Table menu, and choose Formula.  Word opens the Formula dialog box.  Then either key a formula [an instruction on how to perform a calculation] in the Formula text box or accept the proposed formula.  You can also specify number formats or choose a function from Word’s list of frequently used functions.

Additionally, you can calculate a sum by clicking the AutoSum button on the Tables and Borders toolbar.  Word automatically adds numbers in cells above the cell containing the insertion point or in cells to the left of the cell containing the insertion point.  However, when it is possible to add from either direction, AutoSum may not choose the direction you want.  Therefore, always check the accuracy of the result when using AutoSum.

You can also perform other complex math calculations in tables, such as subtracting, multiplying, dividing, averaging, and calculating a percentage.  For calculations, Word assigns letters to columns and numbers to rows as in a worksheet.  Cells are named for their intersecting rows and columns
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•

OBJECTIVES

• Center and AutoFit a table


	You will often want to customize the layout and design of your Word tables.  Word offers some powerful features to help you format tables quickly and easily.

USING AUTOFIT AND Alignment Options

When you create tables, Word inserts the number of columns specified but makes all the columns approximately the same width.  You can adjust the width of each column automatically using the AutoFit feature.  Word offers five autoFit options.  

When you choose to AutoFit to Contents, Word automatically adjusts all column widths as needed to accommodate the contents within the cells.  If you choose the AutoFit to Window option, Word automatically resizes a table to a Web page when you change the window size.

You can choose alignment options for a table in the Table Properties dialog box.   Remember to place the cursor within the table.  If necessary switch to Print Layout view.

Open the Table menu, click Table Properties to open the dialog box, and then choose an alignment in the Alignment section of the Table tab.

The alignment options in this dialog box determine the horizontal alignment of a table.  By default, Word left-aligns tables, but you can also center or right-align the table.  You can also position a table by dragging the move handle at the upper left corner of the table.

Rest the cursor on the upper left corner of the table until the table move handle appears.  Drag the move handle down slightly; then release to position the table lower on the page.  Drag the move handle toward the right edge of the screen; then release

To adjust the height of a row position, put the cursor on the line and drag down and release to increase the height.  To reposition open Table and select distribute rows evenly.
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• Adjust column width and row height


	Generally, when you need to adjust the width of a column, you can simply drag a column border.  But there are other techniques that give you more control over how the other columns adjust.  If you want to see column measurements as you drag on the ruler, hold down ALT as well as the keys listed.

In certain instances, you may want rows or columns to be spaced evenly throughout the table.  Word provides shortcuts for you to distribute the spacing of the rows and columns evenly: the Distribute Rows Evenly and Distribute Columns Evenly buttons on the Tables and Borders toolbar.  To use these buttons, you must first select the rows or columns you want to adjust.

Position the mouse pointer on the ruler at the column marker [box]. When you see the two-headed arrow, drag the marker to move the column.  Notice as you drag that the ruler shifts, rather than just the markers.  After you release, notice that only the second column width changed.

You can double click on the right border of a column to resize a column quickly to accommodate the longest entry in the column.  In some tables, however, you may have to narrow one or more columns before you can double-click to widen another.
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• Convert text to a table

• Insert, delete, and move rows and 

columns


	Generally, you will use Word’s Insert command on the Table menu or the Draw Table tool to create tables. However, on occasion you may want to convert existing text to a table.  Word can quickly convert text separated by commas, tabs, spaces, or other separators into a table with cells.

To create a table from existing text, select the text and then open the Table menu and choose Convert.  Choose Text to Table from the submenu.  The Convert Text to Table dialog box opens.  Based on your selected text, choose how many columns and rows to create.  You can also select AutoFit and AutoFormat options.

Inserting and Deleting Rows and Columns

You can quickly insert a new row into a table by pressing Tab in the last cell of the table.  You can also quickly insert or delete multiple rows and columns in one edit by selecting the desired number of rows or columns you want to add or delete and then choosing the appropriate Table command.

Open Tables and Borders and select.

To insert symbols open the Insert menu and choose or copy from other entries.

You can move rows and columns by drag and drop.  Select entire row or column using the selection pointer by clicking in the row or column and drag.  You can also use cut and paste.
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• Draw, merge, and split table cells


	Merging Table Cells.

Word enables you to remove the boundary between any two cells.  Removing this boundary between cells is called merging cells.  You can merge cells horizontally or vertically.  A quick way to merge cells is to use the Eraser tool on the Tables and Borders tool bar.  As you erase cell borders in the table, the cells are merged.

Adjusting Custom Table Borders and Shading.

In most cases, the default ½ single-line border will be appropriate for the tables you create.  However, on occasion you may want to customize the border and add shading [patters used to shade the background] to some of the table cells.

You can make a number of border and shading changes using the Tables and Borders toolbar.  Some toolbar buttons, such as Outside Border and Shading Options, have a down arrow you click to see a submenu of choices.  If you know you want to make a number of choices from the submenu, you can “float” the menu away from the Tables and Borders toolbar.  Click on the bar at the top of the submenu, and drag the menu to a new location. This way it stays open on your screen
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• Create new table styles 

• Add custom table borders and shading


	Microsoft Word offers many built-in table styles which are already formatted with such things as different borders, shading, and color.  They are ready to use---just input your own data.  Sometimes, however, you might find it necessary to modify an existing table style or create you own style.  If this new style will be used more than once, it makes sense to save this style for future use.

You can use an existing table or one of the table styles provided in the Table AutoFormat dialog box to create a new table style that can be applied to future tables.  Under the category box, select User-defined table styles, and click New.  When the New Style dialog box opens, you can begin adding your own formatting to create a new table style.

Click on Format followed by Styles and Formatting task panes.  If you want the table style to be available for all future documents, turn on the option Add to Template.  The new table style will be added to the Normal template.

In addition to merging table cells, Word allows you to split table cells.  Splitting a cell converts a single table cell into multiple cells.  You can split a cell into two or more rows and/or two or more columns.

The Draw Table tool allows you to use a pen pointer to draw a table boundary just the size you want and then draw column and row lines within the boundary.  To use the pen pointer to draw the boundary, click and drag down and to the right as if you were using the Rectangle drawing tool.  To draw a column or row border start from the boundary and drag down or across.  Word completes the line for you and automatically makes it straight.

To split table cells select the column and click the Split Cells button on the Tables toolbar. Choose the number of columns and rows you wish.
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• Change the direction and alignment of text 

in table cell.

• Link and embed an Excel worksheet into a 

Word document


	Changing Text Alignment and Rotating Text

The Tables and Borders toolbar contains buttons you can use to align text in cells in a number of different ways.  You can align text at the top, center, or bottom of a cell as well as left, center, or right using the alignment options.

You can quickly change the direction of text in a table cell by clicking on the Change Text Direction button on the T & B toolbar. The Change Text Direction button toggles between three text positions.  

Integrating Word and Excel.

There are several ways to import Excel data into a Word document.  You can copy and past worksheet data, or you can insert the worksheet as a linked or embedded object.  The easiest way is to copy and paste.

Creating and Modifying a Worksheet in a Table. 

 At times you might need a more complex table in which you can calculate and instantly recalculate numbers.  The easiest way is to embed an Excel Worksheet which gives you access to all of Excel’s data formatting and calculation options.

Use the Insert Microsoft Excel Worksheet button on the Standard toolbar
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• Create and modify a chart

• Import Excel worksheet data into a chart


	Charts provide a visual display of data and often make the material easier to understand.  Word enables you to convert table data into colorful three-dimensional charts.  There are several options for chart types [column, bar, line, pie, and so forth].  You can also format charts with titles, legends, and labels.

You can create a chart from a table in Word, or you can create a chart from an Excel worksheet and paste or embed the chart into a Word document.

To create a chart, open the Insert menu, click Picture, and then click Chart on the submenu.  Word creates the chart from you data and displays it along with the datasheet, a worksheet-like grid that contains the data used to prepare the chart.  If you need to modify data for the chart, you do so in the datasheet.

You need Microsoft Graph installed in order for you to complete the following exercise.

Open a table in Word.  Select the table.  Open the Insert menu, choose Picture and then Chart.

Click the datasheet’s Close button.

Change the chart type. By opening the Chart menu and choose the Chart Type




_1328535048.ppt


Performing Math Calculations

		EXERCISE

		Open Expense Report

		Sort in descending order

		Calculate total for each column

		Center and bold the column headings

		Right-align the amounts in each column

		Save





Word provides a calculation feature that enables you to add numbers in text and in tables.

When calculating sums in a paragraph of text, you simply select the paragraph and then choose Table Formula command on the Table menu.

When calculating sums in a table, Word provides an easy shortcut to total the columns and/or rows.

To perform a calculation in a table, position the insertion point in the CELL [where a row and column intersect in the table] where the total [result] is to appear, open the Table menu, an choose Formula.  

Word opens the Formula dialog box.  Then either key a formula [an instruction on how to perform a calculation] in the Formula text box or accept the proposed formula.  You can also specify number formats or choose a function from Word’s list of frequently used functions.

Additionally, you can calculate a sum by clicking the AutoSum button on the Tables and Borders toolbar.  Word automatically adds numbers in cells above the cell containing the insertion point or in cells to the left of the cell containing the insertion point.  However, when it is possible to add from either direction, AutoSum may not choose the direction you want.  Therefore, always check the accuracy of the result when using AutoSum.



You can also perform other complex math calculations in tables, such as subtracting, multiplying, dividing, averaging, and calculating a percentage.  For calculations, Word assigns letters to columns and numbers to rows as in a worksheet.  Cells are named for their intersecting rows and columns
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Customizing Tables

		Adjust column width and row height





Generally, when you need to adjust the width of a column, you can simply drag a column border.  But there are other techniques that give you more control over how the other columns adjust.  If you want to see column measurements as you drag on the ruler, hold down ALT as well as the keys listed.



In certain instances, you may want rows or columns to be spaced evenly throughout the table.  Word provides shortcuts for you to distribute the spacing of the rows and columns evenly: the Distribute Rows Evenly and Distribute Columns Evenly buttons on the Tables and Borders toolbar.  To use these buttons, you must first select the rows or columns you want to adjust.



Position the mouse pointer on the ruler at the column marker [box]. When you see the two-headed arrow, drag the marker to move the column.  Notice as you drag that the ruler shifts, rather than just the markers.  After you release, notice that only the second column width changed.



You can double click on the right border of a column to resize a column quickly to accommodate the longest entry in the column.  In some tables, however, you may have to narrow one or more columns before you can double-click to widen another.
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Customizing Tables

		Draw, merge, and split table cells





Merging Table Cells.

Word enables you to remove the boundary between any two cells.  Removing this boundary between cells is called merging cells.  You can merge cells horizontally or vertically.  A quick way to merge cells is to use the Eraser tool on the Tables and Borders tool bar.  As you erase cell borders in the table, the cells are merged.

Adjusting Custom Table Borders and Shading.

In most cases, the default ½ single-line border will be appropriate for the tables you create.  However, on occasion you may want to customize the border and add shading [patters used to shade the background] to some of the table cells.

You can make a number of border and shading changes using the Tables and Borders toolbar.  Some toolbar buttons, such as Outside Border and Shading Options, have a down arrow you click to see a submenu of choices.  If you know you want to make a number of choices from the submenu, you can “float” the menu away from the Tables and Borders toolbar.  Click on the bar at the top of the submenu, and drag the menu to a new location. This way it stays open on your screen
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Customizing Tables



		Change the direction and alignment of text in table cell.

		Link and embed an Excel worksheet into a Word document





Changing Text Alignment and Rotating Text

The Tables and Borders toolbar contains buttons you can use to align text in cells in a number of different ways.  You can align text at the top, center, or bottom of a cell as well as left, center, or right using the alignment options.



You can quickly change the direction of text in a table cell by clicking on the Change Text Direction button on the T & B toolbar. The Change Text Direction button toggles between three text positions.  

Integrating Word and Excel.

There are several ways to import Excel data into a Word document.  You can copy and past worksheet data, or you can insert the worksheet as a linked or embedded object.  The easiest way is to copy and paste.

Creating and Modifying a Worksheet in a Table. 

 At times you might need a more complex table in which you can calculate and instantly recalculate numbers.  The easiest way is to embed an Excel Worksheet which gives you access to all of Excel’s data formatting and calculation options.

Use the Insert Microsoft Excel Worksheet button on the Standard toolbar
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Customizing Tables

		Create and modify a chart

		Import Excel worksheet data into a chart





Charts provide a visual display of data and often make the material easier to understand.  Word enables you to convert table data into colorful three-dimensional charts.  There are several options for chart types [column, bar, line, pie, and so forth].  You can also format charts with titles, legends, and labels.

You can create a chart from a table in Word, or you can create a chart from an Excel worksheet and paste or embed the chart into a Word document.

To create a chart, open the Insert menu, click Picture, and then click Chart on the submenu.  Word creates the chart from you data and displays it along with the datasheet, a worksheet-like grid that contains the data used to prepare the chart.  If you need to modify data for the chart, you do so in the datasheet.

You need Microsoft Graph installed in order for you to complete the following exercise.

Open a table in Word.  Select the table.  Open the Insert menu, choose Picture and then Chart.

Click the datasheet’s Close button.

Change the chart type. By opening the Chart menu and choose the Chart Type










_1328535079.ppt


Customizing Tables

		Create new table styles 

		Add custom table borders and shading





Microsoft Word offers many built-in table styles which are already formatted with such things as different borders, shading, and color.  They are ready to use---just input your own data.  Sometimes, however, you might find it necessary to modify an existing table style or create you own style.  If this new style will be used more than once, it makes sense to save this style for future use.

You can use an existing table or one of the table styles provided in the Table AutoFormat dialog box to create a new table style that can be applied to future tables.  Under the category box, select User-defined table styles, and click New.  When the New Style dialog box opens, you can begin adding your own formatting to create a new table style.

Click on Format followed by Styles and Formatting task panes.  If you want the table style to be available for all future documents, turn on the option Add to Template.  The new table style will be added to the Normal template.

In addition to merging table cells, Word allows you to split table cells.  Splitting a cell converts a single table cell into multiple cells.  You can split a cell into two or more rows and/or two or more columns.

The Draw Table tool allows you to use a pen pointer to draw a table boundary just the size you want and then draw column and row lines within the boundary.  To use the pen pointer to draw the boundary, click and drag down and to the right as if you were using the Rectangle drawing tool.  To draw a column or row border start from the boundary and drag down or across.  Word completes the line for you and automatically makes it straight.

To split table cells select the column and click the Split Cells button on the Tables toolbar. Choose the number of columns and rows you wish.
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Customizing Tables

		Convert text to a table

		Insert, delete, and move rows and columns





Generally, you will use Word’s Insert command on the Table menu or the Draw Table tool to create tables. However, on occasion you may want to convert existing text to a table.  Word can quickly convert text separated by commas, tabs, spaces, or other separators into a table with cells.



To create a table from existing text, select the text and then open the Table menu and choose Convert.  Choose Text to Table from the submenu.  The Convert Text to Table dialog box opens.  Based on your selected text, choose how many columns and rows to create.  You can also select AutoFit and AutoFormat options.



Inserting and Deleting Rows and Columns

You can quickly insert a new row into a table by pressing Tab in the last cell of the table.  You can also quickly insert or delete multiple rows and columns in one edit by selecting the desired number of rows or columns you want to add or delete and then choosing the appropriate Table command.

Open Tables and Borders and select.

To insert symbols open the Insert menu and choose or copy from other entries.

You can move rows and columns by drag and drop.  Select entire row or column using the selection pointer by clicking in the row or column and drag.  You can also use cut and paste.
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Customizing Tables

		OBJECTIVES

		Center and AutoFit a table





You will often want to customize the layout and design of your Word tables.  Word offers some powerful features to help you format tables quickly and easily.

USING AUTOFIT AND Alignment Options

When you create tables, Word inserts the number of columns specified but makes all the columns approximately the same width.  You can adjust the width of each column automatically using the AutoFit feature.  Word offers five autoFit options.  

When you choose to AutoFit to Contents, Word automatically adjusts all column widths as needed to accommodate the contents within the cells.  If you choose the AutoFit to Window option, Word automatically resizes a table to a Web page when you change the window size.

You can choose alignment options for a table in the Table Properties dialog box.   Remember to place the cursor within the table.  If necessary switch to Print Layout view..

Open the Table menu, click Table Properties to open the dialog box, and then choose an alignment in the Alignment section of the Table tab.

The alignment options in this dialog box determine the horizontal alignment of a table.  By default, Word left-aligns tables, but you can also center or right-align the table.  You can also position a table by dragging the move handle at the upper left corner of the table.

Rest the cursor on the upper left corner of the table until the table move handle appears.  Drag the move handle down slightly; then release to position the table lower on the page.  Drag the move handle toward the right edge of the screen; then release

To adjust the height of a row position the cursor on the line and drag down and release to increase the height.  To reposition open Table and select distribute rows evenly.
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Sorting single-Column Lists

		Each time you sort during a Word session, the previous sort settings are retained.  Be sure to check all settings before you click OK to sort.





When entering text, you do not need to enter list items in order.  You can use Word’s Sort Feature to reorder list items in a number of ways.



To sort a list [or to perform any other kind of sort]. open the Table menu and choose Sort.  The Sort Text dialog box opens.



Perform a simple sort by selecting the item to sort by [usually Paragraphs] and type of item to sort [text, number, or date].  Choose the Ascending or Descending option, and then click OK.  Notice that you can sort by more than one criterion using the additional Then by boxes.



Clicking the OPTIONS button in the Sort Text dialog box opens the Sort Options dialog box.  In this dialog box, Word gives you additional options for controlling the sort.  For paragraphs that contain more than single words, you can instruct Word to sort text by FIELDS.  In this case, the fields are a single piece of information, such as the first word or the second word.  Tabs, commas, or other characters may separate the fields.  Click the CASE SENSITIVE option to have Word sort by both upper- and lowercase letters.  
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Sorting Tables

		Name			Title		Department	Date Hired

		Lisa Foster-Hale		Director		Legal		3-15-71

		Roger Lee		Director		Public Relations	4-5-80

		Terry Curran		Manager		Personnel		7-14-82

		Shelley Metzger		Administrative A	Finance		6-30-85

		Lucille Graszl		Administrative 	Legal		1-16-88

		Larry CraszlSales 		Representative	Marketing		12-17-89

		Richard Derrenberger	Clerk III		Accounting		4-6-90

		Mildred RushSales	 Representative	Marketing		2-7-91

		Anne Pheifer		Receptionist	Personnel		9-14-92





When sorting table data, you can sort a single column or the entire table.

When you want the entire table sorted based on the first column, you can use a button the Tables and Borders toolbar to perform the sort automatically.  If the result is not what you expected, you can open the Table menu, choose Sort, and check the settings.



Furthermore, you can sort by multiple words contained within a single table column.  For example, if the column contains both first and last names, you can sort by either the last name or the first name.
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Advanced Microsoft Word

Sorting and Calculating



Sorting Text:  Microsoft Office allows you to rearrange your text by numbers first, then letters [alphanumerically]; by numbers only’ or by date.  You can sort tables, paragraphs, or lists created with commas, tabs, spaces, or other separators.  You can sort in either ascending [A to Z 1 to 10, earliest date to the latest date.] or descending  [Z to A, 10 to 1, latest date to earliest] order.



Any blank lines you have inserted between paragraphs in your document will automatically be moved to the top or bottom of the selection during the sort.










